logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

slixmpp-1.4.2.ebuild (798B)


  1. # Copyright 1999-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. PYTHON_COMPAT=( python3_{6,7} )
  5. inherit distutils-r1
  6. DESCRIPTION="Python 3 library for XMPP"
  7. HOMEPAGE="https://dev.louiz.org/projects/slixmpp"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. IUSE="test"
  11. RESTRICT="!test? ( test )"
  12. if [[ "${PV}" == "9999" ]]; then
  13. EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git"
  14. inherit git-r3
  15. else
  16. SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
  17. KEYWORDS="~amd64"
  18. fi
  19. RDEPEND="
  20. dev-python/aiodns[${PYTHON_USEDEP}]
  21. dev-python/aiohttp[${PYTHON_USEDEP}]
  22. dev-python/pyasn1-modules[${PYTHON_USEDEP}]
  23. dev-python/pyasn1[${PYTHON_USEDEP}]
  24. "
  25. DEPEND="
  26. dev-python/setuptools[${PYTHON_USEDEP}]
  27. net-dns/libidn
  28. test? ( $RDEPEND )
  29. "
  30. python_test() {
  31. esetup.py test
  32. }