logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

pygame_sdl2-7.3.5.ebuild (937B)


  1. # Copyright 1999-2019 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. PYTHON_COMPAT=( python{2_7,3_5,3_6} )
  5. inherit distutils-r1
  6. PYSDL="${PN}-2.1.0"
  7. DESCRIPTION="Reimplementation of portions of the pygame API using SDL2"
  8. HOMEPAGE="https://github.com/renpy/pygame_sdl2"
  9. SRC_URI="http://www.renpy.org/dl/${PV}/${PYSDL}-for-renpy-${PV}.tar.gz"
  10. LICENSE="LGPL-2.1 ZLIB"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE=""
  14. BDEPEND="
  15. dev-python/cython[${PYTHON_USEDEP}]"
  16. DEPEND="
  17. dev-python/numpy[${PYTHON_USEDEP}]
  18. media-libs/libpng:0=
  19. media-libs/libsdl2:=[video]
  20. media-libs/sdl2-image:=[png,jpeg]
  21. >=media-libs/sdl2-mixer-2.0.2:=
  22. media-libs/sdl2-ttf:=
  23. virtual/jpeg:0"
  24. RDEPEND="${DEPEND}"
  25. S=${WORKDIR}/${PYSDL}-for-renpy-${PV}
  26. # PyGame distribution for this version has some pregenerated files;
  27. # we need to remove them
  28. python_prepare_all()
  29. {
  30. rm -r gen{,3} || die
  31. distutils-r1_python_prepare_all
  32. }