logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

livereload-2.6.1.ebuild (806B)


  1. # Copyright 1999-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. PYTHON_COMPAT=( python3_6 python3_7 )
  5. inherit distutils-r1
  6. distutils_enable_tests nose
  7. DESCRIPTION="Python LiveReload is an awesome tool for web developers"
  8. HOMEPAGE="https://github.com/lepture/python-livereload"
  9. SRC_URI="https://github.com/lepture/python-${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  10. LICENSE="BSD"
  11. SLOT="0"
  12. KEYWORDS="~amd64"
  13. IUSE="examples test"
  14. RESTRICT="test? ( test )"
  15. CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
  16. DEPEND="${CDEPEND}"
  17. RDEPEND="
  18. ${CDEPEND}
  19. dev-python/six[${PYTHON_USEDEP}]
  20. www-servers/tornado[${PYTHON_USEDEP}]
  21. "
  22. S="${WORKDIR}/python-${P}"
  23. python_install_all() {
  24. use examples && local EXAMPLES=( example/. )
  25. distutils-r1_python_install_all
  26. }