logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

Net-CVE-0.006.ebuild (585B)


  1. # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DIST_AUTHOR=HMBRAND
  5. DIST_A_EXT=tgz
  6. inherit perl-module
  7. DESCRIPTION="Fetch CVE (Common Vulnerabilities and Exposures) information from cve.org"
  8. SLOT="0"
  9. KEYWORDS="~amd64"
  10. RDEPEND="
  11. dev-perl/IO-Socket-SSL
  12. dev-perl/JSON-MaybeXS
  13. virtual/perl-Scalar-List-Utils
  14. virtual/perl-Carp
  15. virtual/perl-HTTP-Tiny
  16. "
  17. BDEPEND="
  18. ${RDEPEND}
  19. test? ( dev-perl/Test-Warnings )
  20. "
  21. PATCHES=(
  22. "${FILESDIR}/0001-t-30-get.t-Skip-on-NO_NETWORK_TESTING.patch"
  23. )