Net-CVE-0.006.ebuild (585B)
- # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
- # Distributed under the terms of the GNU General Public License v2
- EAPI=8
- DIST_AUTHOR=HMBRAND
- DIST_A_EXT=tgz
- inherit perl-module
- DESCRIPTION="Fetch CVE (Common Vulnerabilities and Exposures) information from cve.org"
- SLOT="0"
- KEYWORDS="~amd64"
- RDEPEND="
- dev-perl/IO-Socket-SSL
- dev-perl/JSON-MaybeXS
- virtual/perl-Scalar-List-Utils
- virtual/perl-Carp
- virtual/perl-HTTP-Tiny
- "
- BDEPEND="
- ${RDEPEND}
- test? ( dev-perl/Test-Warnings )
- "
- PATCHES=(
- "${FILESDIR}/0001-t-30-get.t-Skip-on-NO_NETWORK_TESTING.patch"
- )