logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

ws-8.13.0-r1.ebuild (806B)


  1. # Copyright 2022-2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit nodejs optfeature
  5. DESCRIPTION="Simple to use, blazing fast and thoroughly tested WebSocket client and server for Node.js"
  6. HOMEPAGE="https://github.com/websockets/ws"
  7. SRC_URI="https://github.com/websockets/ws/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. RESTRICT="test"
  12. DOCS=( SECURITY.md README.md doc examples )
  13. pkg_postinst() {
  14. if has_version '<dev-lang/nodejs-18.14.0'; then
  15. optfeature "(<nodejs-18.14.0) efficiently check if a message contains valid UTF-8" \
  16. dev-nodejs/utf-8-validate
  17. fi
  18. optfeature "efficiently perform operations such as masking and unmasking" \
  19. dev-nodejs/bufferutil
  20. }