logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

which-4.0.0.ebuild (647B)


  1. # Copyright 2022 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit nodejs
  5. DESCRIPTION="Like which(1) unix command. Find the first instance of an executable in the PATH."
  6. HOMEPAGE="https://github.com/isaacs/node-which"
  7. SRC_URI="https://github.com/isaacs/node-which/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  8. S="${WORKDIR}/node-which-${PV}"
  9. LICENSE="ISC"
  10. SLOT="0"
  11. KEYWORDS="~amd64"
  12. #IUSE="test"
  13. RDEPEND="dev-nodejs/isexe"
  14. DEPEND="${RDEPEND}"
  15. #test? (
  16. # dev-nodejs/mkdirp
  17. # dev-nodejs/rimraf
  18. # dev-nodejs/tap
  19. #)"
  20. #RESTRICT="!test? ( test )"
  21. RESTRICT="test"