logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

shell-quote-1.8.1.ebuild (711B)


  1. # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit nodejs
  5. DESCRIPTION="quote and parse shell commands"
  6. HOMEPAGE="https://github.com/ljharb/shell-quote"
  7. SRC_URI="https://github.com/ljharb/shell-quote/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="test"
  12. RESTRICT="!test? ( test )"
  13. DEPEND="test? ( dev-nodejs/tape-lite )"
  14. BDEPEND="dev-util/esbuild"
  15. src_prepare() {
  16. default
  17. #sed -i '/"tests-only": /s;nyc tape;node --test;' package.json || die
  18. sed -i "s;require('tape');require('tape-lite');;" test/*.js || die
  19. }
  20. src_test() {
  21. node --test test/*.js || die
  22. }