logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

semver-7.5.4.ebuild (537B)


  1. # Copyright 2022 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit nodejs
  5. DESCRIPTION="semantic version parser used by npm"
  6. HOMEPAGE="https://github.com/npm/node-semver"
  7. SRC_URI="https://github.com/npm/node-semver/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  8. S="${WORKDIR}/node-${P}"
  9. LICENSE="ISC"
  10. SLOT="0"
  11. KEYWORDS="~amd64"
  12. IUSE="test"
  13. #RESTRICT="!test? ( test )"
  14. #DEPEND="test? ( dev-nodejs/tap )"
  15. RDEPEND="dev-nodejs/lru-cache"
  16. RESTRICT="test"