logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

nopt-6.0.0.ebuild (670B)


  1. # Copyright 2022 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit nodejs
  5. DESCRIPTION="ion parsing for Node, supporting types, shorthands, etc"
  6. HOMEPAGE="https://github.com/npm/nopt"
  7. SRC_URI="https://github.com/npm/nopt/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="ISC"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="test"
  12. #RESTRICT="!test? ( test )"
  13. #DEPEND="test? ( dev-nodejs/tap )"
  14. RDEPEND="dev-nodejs/abbrev"
  15. RESTRICT="test"
  16. src_install() {
  17. insinto "${NODEJS_SITELIB}${PN}"
  18. doins package.json
  19. cat package.json | jq -r .files[] | while read pkg
  20. do
  21. doins -r "$pkg"
  22. done
  23. }