logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

node-bindings-1.5.0.ebuild (496B)


  1. # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit nodejs
  5. DESCRIPTION="Helper module for loading your native module's .node file"
  6. HOMEPAGE="https://github.com/TooTallNate/node-bindings"
  7. SRC_URI="https://github.com/TooTallNate/node-bindings/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. RDEPEND="dev-nodejs/file-uri-to-path"
  12. RESTRICT="test" # no tests