logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

mkdirp-1.0.4.ebuild (568B)


  1. # Copyright 2022 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit nodejs
  5. DESCRIPTION="Recursively mkdir, like 'mkdir -p', but in node.js"
  6. HOMEPAGE="https://github.com/isaacs/node-mkdirp"
  7. SRC_URI="https://github.com/isaacs/node-mkdirp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  8. S="${WORKDIR}/node-mkdirp-${PV}"
  9. LICENSE="MIT"
  10. SLOT="0"
  11. KEYWORDS="~amd64"
  12. #IUSE="test"
  13. #RESTRICT="!test? ( test )"
  14. #DEPEND="test? (
  15. # dev-nodejs/tap
  16. # dev-nodejs/require-inject
  17. #)"
  18. RESTRICT="test"