logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

minimist-1.2.8.ebuild (606B)


  1. # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit nodejs
  5. DESCRIPTION="parse argument options"
  6. HOMEPAGE="https://github.com/minimistjs/minimist"
  7. SRC_URI="https://github.com/minimistjs/minimist/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="test"
  12. RESTRICT="!test? ( test )"
  13. DEPEND="test? ( dev-nodejs/tape-lite )"
  14. src_prepare() {
  15. default
  16. sed -i "s;require('tape');require('tape-lite');;" test/*.js || die
  17. }
  18. src_test() {
  19. node --test test/*.js || die
  20. }