logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

mecab-async-0.1.2.ebuild (756B)


  1. # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit nodejs
  5. DESCRIPTION="Asynchronous japanese morphological analyser using MeCab"
  6. HOMEPAGE="https://github.com/hecomi/node-mecab-async"
  7. # No tags in the git repo, use version-change commit
  8. EGIT_COMMIT="f3b2b9ce10914c7b3ff3b69cc09991d8df2e4aee"
  9. SRC_URI="https://github.com/hecomi/node-mecab-async/archive/${EGIT_COMMIT}.tar.gz -> node-${PN}-${EGIT_COMMIT}.tar.gz"
  10. S="${WORKDIR}/node-${PN}-${EGIT_COMMIT}/"
  11. LICENSE="MIT"
  12. SLOT="0"
  13. KEYWORDS="~amd64"
  14. IUSE="test"
  15. RESTRICT="!test? ( test )"
  16. RDEPEND="
  17. dev-nodejs/shell-quote
  18. app-text/mecab
  19. "
  20. DEPEND="test? ( ${RDEPEND} )"
  21. src_test() {
  22. node test.js || die
  23. }