logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

glob-8.0.3.ebuild (840B)


  1. # Copyright 2022 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit nodejs
  5. DESCRIPTION="little globber"
  6. HOMEPAGE="https://github.com/isaacs/node-glob"
  7. SRC_URI="https://github.com/isaacs/node-glob/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  8. S="${WORKDIR}/node-${P}"
  9. LICENSE="ISC"
  10. SLOT="0"
  11. KEYWORDS="~amd64"
  12. #IUSE="test"
  13. #RESTRICT="!test? ( test )"
  14. #DEPEND="test? (
  15. # dev-nodejs/memfs
  16. # dev-nodejs/mkdirp
  17. # dev-nodejs/rimraf
  18. # dev-nodejs/tap
  19. # dev-nodejs/tick
  20. #)"
  21. RDEPEND="
  22. dev-nodejs/fs-realpath
  23. dev-nodejs/inflight
  24. dev-nodejs/inherits
  25. dev-nodejs/minimatch
  26. dev-nodejs/once
  27. "
  28. RESTRICT="test"
  29. src_install() {
  30. insinto "${NODEJS_SITELIB}${PN}"
  31. doins package.json
  32. cat package.json | jq -r .files[] | while read pkg
  33. do
  34. doins -r "$pkg"
  35. done
  36. }