logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

fs-realpath-1.0.0.ebuild (739B)


  1. # Copyright 2022 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit nodejs
  5. MY_P=fs.realpath-${PV}
  6. DESCRIPTION="Use node's fs.realpath, but fall back to the JS implementation if the native one fails"
  7. HOMEPAGE="https://github.com/isaacs/fs.realpath"
  8. SRC_URI="https://github.com/isaacs/fs.realpath/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  9. S="${WORKDIR}/${MY_P}"
  10. LICENSE="ISC"
  11. SLOT="0"
  12. KEYWORDS="~amd64"
  13. IUSE="test"
  14. #RESTRICT="!test? ( test )"
  15. #DEPEND="test? ( dev-nodejs/tap )"
  16. RESTRICT="test"
  17. src_install() {
  18. insinto "${NODEJS_SITELIB}${PN}"
  19. doins package.json
  20. cat package.json | jq -r .files[] | while read pkg
  21. do
  22. doins -r "$pkg"
  23. done
  24. }