logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

file-uri-to-path-2.0.0.ebuild (622B)


  1. # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit nodejs
  5. DESCRIPTION="Convert a file: URI to a file path"
  6. HOMEPAGE="https://github.com/TooTallNate/file-uri-to-path"
  7. SRC_URI="https://github.com/TooTallNate/file-uri-to-path/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. BDEPEND="dev-util/esbuild"
  12. # heavy test deps like mocha
  13. RESTRICT="test"
  14. src_compile() {
  15. # Default is tsc (TypeScript compiler) which doesn't bootstraps from source
  16. esbuild src/index.ts --outdir=dist/src
  17. }