logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

exit-0.1.2.ebuild (681B)


  1. # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit nodejs
  5. DESCRIPTION="replacement for process.exit that ensures stdio are fully drained before exiting"
  6. HOMEPAGE="https://github.com/cowboy/node-exit"
  7. SRC_URI="https://github.com/cowboy/node-exit/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  8. S="${WORKDIR}/node-${P}"
  9. LICENSE="MIT"
  10. SLOT="0"
  11. KEYWORDS="~amd64"
  12. #IUSE="test"
  13. #RESTRICT="!test? ( test )"
  14. #DEPEND="test? (
  15. # dev-nodejs/grunt-contrib-jshint
  16. # dev-nodejs/grunt-contrib-nodeunit
  17. # dev-nodejs/grunt-contrib-watch
  18. # dev-nodejs/grunt
  19. # dev-nodejs/which
  20. #)"
  21. RESTRICT="test"