logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

cli-1.0.1.ebuild (621B)


  1. # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit nodejs
  5. DESCRIPTION="toolkit for rapidly building command line apps"
  6. HOMEPAGE="https://github.com/node-js-libs/cli"
  7. SRC_URI="https://github.com/node-js-libs/cli/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. # no tests
  12. RESTRICT="test"
  13. RDEPEND="
  14. dev-nodejs/glob
  15. dev-nodejs/exit
  16. "
  17. DOCS=( README.md examples )
  18. src_install() {
  19. einstalldocs
  20. insinto "${NODEJS_SITELIB}${PN}"
  21. doins package.json
  22. doins index.js
  23. doins cli.js
  24. }