logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

chipmunk-6.1.2.ebuild (568B)


  1. # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit nodejs
  5. DESCRIPTION="Port of slembcke/Chipmunk-Physics to Javascript"
  6. HOMEPAGE="https://github.com/josephg/Chipmunk-js"
  7. SRC_URI="https://github.com/josephg/Chipmunk-js/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  8. S="${WORKDIR}/Chipmunk-js-${PV}"
  9. LICENSE="MIT"
  10. SLOT="0"
  11. KEYWORDS="~amd64"
  12. DEPEND="dev-util/uglifyjs"
  13. # no testsuite
  14. RESTRICT="test"
  15. src_prepare() {
  16. default
  17. emake clean
  18. }
  19. src_compile() {
  20. emake
  21. }