logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

chem-4.1.1.ebuild (533B)


  1. # Copyright 2022 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit nodejs
  5. DESCRIPTION="2d canvas-based rapid prototyping game engine"
  6. HOMEPAGE="https://github.com/andrewrk/chem"
  7. SRC_URI="https://github.com/andrewrk/chem/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. # No testsuite
  12. RESTRICT="test"
  13. RDEPEND="
  14. >=dev-nodejs/vec2d-0.3.0
  15. >=dev-nodejs/pend-1.1.3
  16. "
  17. DEPEND="${RDEPEND}"
  18. DOCS=( doc README.md )