logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

brace-expansion-2.0.1.ebuild (896B)


  1. # Copyright 2022-2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit nodejs
  5. DESCRIPTION="Brace expansion, as known from sh/bash, in JavaScript"
  6. HOMEPAGE="https://github.com/juliangruber/brace-expansion"
  7. SRC_URI="https://github.com/juliangruber/brace-expansion/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="test"
  12. RESTRICT="!test? ( test )"
  13. RDEPEND="dev-nodejs/balanced-match"
  14. DEPEND="
  15. ${RDEPEND}
  16. test? ( dev-nodejs/tape-lite )
  17. "
  18. # Note: [PR60] switches to node:test, but doesn't cleanly applies on 2.0.1
  19. # PR60: https://github.com/juliangruber/brace-expansion/pull/60
  20. src_prepare() {
  21. default
  22. sed -i 's;tape test/\*.js;node --test;' package.json || die
  23. sed -i "s;require('tape');require('tape-lite');" test/*.js || die
  24. rm test/perf/bench.js || die
  25. }