logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

balanced-match-3.0.1.ebuild (774B)


  1. # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit nodejs
  5. DESCRIPTION="Match balanced character pairs, like { and }"
  6. HOMEPAGE="https://github.com/juliangruber/balanced-match"
  7. SRC_URI="https://github.com/juliangruber/balanced-match/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="3"
  10. KEYWORDS="~amd64"
  11. IUSE="test"
  12. RESTRICT="!test? ( test )"
  13. src_prepare() {
  14. default
  15. # standard: linter; no need in a distro package
  16. sed -i 's;"test": "standard --fix && node--test;"test": "node --test;' package.json || die
  17. # 'test' is just a port of 'node:test' from NodeJS 18+
  18. sed -i "s;import test from 'test';import test from 'node:test';" test/test.js || die
  19. }