logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

abbrev-1.1.1.ebuild (682B)


  1. # Copyright 2022 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit nodejs
  5. DESCRIPTION="Get unique abbreviations for a set of strings"
  6. HOMEPAGE="https://github.com/npm/abbrev-js"
  7. SRC_URI="https://github.com/npm/abbrev-js/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  8. S="${WORKDIR}/abbrev-js-${PV}"
  9. LICENSE="ISC" # ISC OR MIT
  10. SLOT="0"
  11. KEYWORDS="~amd64"
  12. IUSE="test"
  13. #RESTRICT="!test? ( test )"
  14. #DEPEND="test? ( dev-nodejs/tap )"
  15. RESTRICT="test"
  16. src_install() {
  17. insinto "${NODEJS_SITELIB}${PN}"
  18. doins package.json
  19. cat package.json | jq -r .files[] | while read pkg
  20. do
  21. doins "$pkg"
  22. done
  23. }