logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

luasec-0.7.ebuild (1065B)


  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  3. # Distributed under the terms of the GNU General Public License v2
  4. EAPI=6
  5. IS_MULTILIB=true
  6. inherit lua
  7. DESCRIPTION="Lua binding for OpenSSL library to provide TLS/SSL communication."
  8. HOMEPAGE="http://www.inf.puc-rio.br/~brunoos/luasec/"
  9. SRC_URI="https://github.com/brunoos/luasec/archive/${P}.tar.gz"
  10. LUA_S="${PN}-${P}"
  11. LICENSE="MIT"
  12. SLOT="0"
  13. KEYWORDS="~amd64 ~arm ~x86"
  14. IUSE="examples libressl"
  15. RDEPEND="
  16. dev-lua/luasocket
  17. !libressl? ( dev-libs/openssl:= )
  18. libressl? ( dev-libs/libressl:= )
  19. "
  20. DEPEND="
  21. ${RDEPEND}
  22. "
  23. all_lua_prepare() {
  24. sed -i -r \
  25. -e 's#(MAKE\)).*(install)#\1 \2#' \
  26. -e '/LIB_PATH.*-L.usr.lib/d' \
  27. Makefile
  28. pushd src &>/dev/null
  29. lua_default
  30. popd &>/dev/null
  31. }
  32. each_lua_configure() {
  33. pushd src &>/dev/null
  34. myeconfargs=()
  35. myeconfargs+=(
  36. LD='$(CC)'
  37. LUAPATH="$(lua_get_pkgvar INSTALL_LMOD)"
  38. LUACPATH="$(lua_get_pkgvar INSTALL_CMOD)"
  39. )
  40. lua_default
  41. popd &>/dev/null
  42. }
  43. each_lua_compile() {
  44. lua_default linux
  45. }