logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

luaevent-0.4.6.ebuild (534B)


  1. # Copyright 1999-2019 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit lua
  5. DESCRIPTION="libevent bindings for Lua"
  6. HOMEPAGE="http://luaforge.net/projects/luaevent/"
  7. SRC_URI="https://github.com/harningt/luaevent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~x86"
  11. IUSE=""
  12. RDEPEND="
  13. dev-libs/libevent:0=
  14. "
  15. DEPEND="
  16. ${RDEPEND}
  17. virtual/pkgconfig
  18. "
  19. DOCS=(README)
  20. each_lua_install() {
  21. dolua lua/*
  22. _dolua_insdir="${PN}" \
  23. dolua core.so
  24. }