logo

overlay

My (experimental) gentoo overlay

luaevent-0.4.4.ebuild (533B)


      1 # Copyright 1999-2019 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit lua
      7 
      8 DESCRIPTION="libevent bindings for Lua"
      9 HOMEPAGE="http://luaforge.net/projects/luaevent"
     10 SRC_URI="https://github.com/harningt/luaevent/archive/v${PV}.tar.gz -> ${P}.tar.gz"
     11 
     12 LICENSE="LGPL-2.1"
     13 SLOT="0"
     14 KEYWORDS="~amd64 ~arm ~x86"
     15 IUSE=""
     16 
     17 RDEPEND="
     18 	dev-libs/libevent:0=
     19 "
     20 DEPEND="
     21 	${RDEPEND}
     22 	virtual/pkgconfig
     23 "
     24 
     25 DOCS=(README)
     26 
     27 each_lua_install() {
     28 	dolua lua/*
     29 	_dolua_insdir="${PN}" \
     30 	dolua core.so
     31 }