logo

overlay

My (experimental) gentoo overlay

wpebackend-fdo-1.4.0.ebuild (655B)


      1 # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 CMAKE_MAKEFILE_GENERATOR="ninja"
      6 
      7 inherit cmake-utils
      8 
      9 DESCRIPTION="FreeDesktop.Org backend for WPE WebKit"
     10 HOMEPAGE="https://wpewebkit.org/"
     11 LICENSE="BSD-2"
     12 SRC_URI="https://wpewebkit.org/releases/${P}.tar.xz"
     13 SLOT="1.0" # WPE_API_VERSION
     14 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x86-macos"
     15 IUSE=""
     16 
     17 # documentation depends on hotdoc
     18 DEPEND="
     19 	media-libs/mesa[egl]
     20 	dev-libs/glib:=
     21 	>=dev-libs/wayland-1.10:=
     22 	net-libs/libwpe:=
     23 "
     24 RDEPEND="${DEPEND}"