logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

socket99-0.2.2.ebuild (552B)


  1. # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit flag-o-matic
  5. DESCRIPTION="Wrapper library for the BSD sockets API with a nicer C99 interface"
  6. HOMEPAGE="https://github.com/silentbicycle/socket99"
  7. SRC_URI="https://github.com/silentbicycle/socket99/archive/v0.2.2.tar.gz -> ${P}.tar.gz"
  8. LICENSE="ISC"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. src_compile() {
  12. append-cflags "-fPIC"
  13. emake "lib${PN}.a"
  14. }
  15. src_install() {
  16. dolib.a "lib${PN}.a"
  17. doheader "${PN}.h"
  18. }