logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

libvterm-1.3.4_pre769.ebuild (883B)


  1. # Copyright 1999-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit libtool flag-o-matic
  5. # one-indexed: [1, 3, 4, pre, 769]
  6. MY_PV="$(ver_cut 5)"
  7. DESCRIPTION="An abstract library implementation of a VT220/xterm/ECMA-48 terminal emulator"
  8. HOMEPAGE="http://www.leonerd.org.uk/code/libvterm/"
  9. SRC_URI="https://bazaar.launchpad.net/~libvterm/libvterm/trunk/tarball/${MY_PV} -> ${P}.tar.gz"
  10. LICENSE="MIT"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. DEPEND="
  14. sys-devel/libtool
  15. virtual/pkgconfig
  16. "
  17. RDEPEND="!dev-libs/libvterm-neovim"
  18. S="${WORKDIR}/~libvterm/libvterm/trunk/"
  19. src_compile() {
  20. append-cflags -fPIC
  21. emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)"
  22. }
  23. src_install() {
  24. emake \
  25. PREFIX="${EPREFIX}/usr" \
  26. LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
  27. DESTDIR="${D}" install
  28. find "${D}" -name '*.la' -delete
  29. }