logo

overlay

My own overlay for experimentations, use with caution, no support is provided

libvterm-0.0_pre767.ebuild (821B)


      1 # Copyright 1999-2020 Gentoo Authors
      2 # Distributed under the terms of the GNU General Public License v2
      3 
      4 EAPI=7
      5 
      6 inherit libtool flag-o-matic
      7 
      8 DESCRIPTION="An abstract library implementation of a VT220/xterm/ECMA-48 terminal emulator"
      9 HOMEPAGE="http://www.leonerd.org.uk/code/libvterm/"
     10 SRC_URI="https://bazaar.launchpad.net/~libvterm/libvterm/trunk/tarball/767 -> ${P}.tar.gz"
     11 
     12 LICENSE="MIT"
     13 SLOT="0"
     14 KEYWORDS="~amd64 ~x86"
     15 
     16 DEPEND="
     17 	sys-devel/libtool
     18 	virtual/pkgconfig
     19 "
     20 
     21 RDEPEND="!dev-libs/libvterm-neovim"
     22 
     23 S="${WORKDIR}/~libvterm/libvterm/trunk/"
     24 
     25 src_compile() {
     26 	append-cflags -fPIC
     27 	emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)"
     28 }
     29 
     30 src_install() {
     31 	emake \
     32 		PREFIX="${EPREFIX}/usr" \
     33 		LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
     34 		DESTDIR="${D}" install
     35 
     36 	find "${D}" -name '*.la' -delete
     37 }