logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

libucl-0.8.1.ebuild (813B)


  1. # Copyright 2020 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit autotools
  5. DESCRIPTION="Universal configuration library parser"
  6. HOMEPAGE="https://github.com/vstakhov/libucl"
  7. SRC_URI="https://github.com/vstakhov/libucl/archive/0.8.1.tar.gz -> ${P}.tar.gz"
  8. LICENSE="BSD-2"
  9. SLOT="0/5.1.0"
  10. KEYWORDS="~amd64"
  11. IUSE="curl openssl libressl lua +static-libs utils"
  12. DEPENDS="
  13. curl? ( net-misc/curl )
  14. openssl? (
  15. !libressl? ( dev-libs/openssl:0= )
  16. libressl? ( dev-libs/libressl:= )
  17. )
  18. lua? ( dev-lang/lua:= )
  19. "
  20. src_prepare() {
  21. default
  22. eautoreconf
  23. }
  24. src_configure() {
  25. econf \
  26. $(use_enable static-libs static) \
  27. $(use_enable curl urls) \
  28. $(use_enable openssl signatures) \
  29. $(use_enable lua) \
  30. $(use_enable utils)
  31. }