logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

libtomcrypt-1.18.2.ebuild (945B)


  1. # Copyright 2018 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit toolchain-funcs flag-o-matic
  5. DESCRIPTION="modular and portable cryptographic toolkit"
  6. HOMEPAGE="https://www.libtom.net/LibTomCrypt/"
  7. SRC_URI="https://github.com/libtom/libtomcrypt/releases/download/v${PV}/crypt-${PV}.tar.xz"
  8. LICENSE="WTFPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="doc"
  12. RDEPEND="dev-libs/libtommath"
  13. DEPEND="${RDEPEND}
  14. doc? ( virtual/latex-base app-text/ghostscript-gpl )"
  15. src_compile() {
  16. append-flags "-DUSE_LTM -DLTM_DESC"
  17. EXTRALIBS="-ltommath" \
  18. CC=$(tc-getCC) \
  19. IGNORE_SPEED=1 \
  20. emake -f makefile.shared || die "emake failed"
  21. use doc && emake emake -f makefile.shared docs
  22. }
  23. src_install() {
  24. emake -f makefile.shared install PREFIX="/usr" DESTDIR="${D}" LIBPATH="/usr/$(get_libdir)"
  25. use doc && emake -f makefile.shared install_docs PREFIX="/usr" DESTDIR="${D}"
  26. }