logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

libtls-bearssl-0.5.ebuild (795B)


  1. # Copyright 2024 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit toolchain-funcs
  5. DESCRIPTION="libtls implemented with bearssl"
  6. HOMEPAGE="https://sr.ht/~mcf/libtls-bearssl"
  7. SRC_URI="https://git.sr.ht/~mcf/libtls-bearssl/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="ISC"
  9. # See shlib_version
  10. SLOT="0/20.3"
  11. KEYWORDS="~amd64"
  12. IUSE=""
  13. RDEPEND="
  14. dev-libs/bearssl:=
  15. !dev-libs/libretls
  16. "
  17. DEPEND="${RDEPEND}"
  18. src_configure() {
  19. export PREFIX=/usr
  20. export LIBDIR="${EPREFIX}/usr/$(get_libdir)/"
  21. tc-export CC AR
  22. export CFLAGS="$CFLAGS $(pkg-config --cflags libbearssl)"
  23. export LDLIBS="$(pkg-config --libs libbearssl) -l pthread"
  24. sed -i 's;Libs.private: -lbearssl;Requires: libbearssl;' libtls.pc.in || die
  25. }