logo

overlay

My (experimental) gentoo overlay

libtermkey-0.21.1-r1.ebuild (1095B)


      1 # Copyright 1999-2018 Gentoo Foundation
      2 # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
      3 # Distributed under the terms of the GNU General Public License v2
      4 
      5 EAPI=7
      6 inherit flag-o-matic
      7 
      8 DESCRIPTION="Library for easy processing of keyboard entry from terminal-based programs"
      9 HOMEPAGE="http://www.leonerd.org.uk/code/libtermkey/"
     10 SRC_URI="http://www.leonerd.org.uk/code/${PN}/${P}.tar.gz"
     11 
     12 LICENSE="MIT"
     13 SLOT="0"
     14 KEYWORDS="~amd64 ~x86"
     15 IUSE="demos static-libs"
     16 
     17 RDEPEND="dev-libs/unibilium:="
     18 DEPEND="${RDEPEND}
     19 	sys-devel/libtool
     20 	virtual/pkgconfig
     21 	demos? ( dev-libs/glib:2 )"
     22 
     23 PATCHES=( "${FILESDIR}/${P}_no_manpage_compression.patch" )
     24 
     25 src_prepare() {
     26 	default
     27 
     28 	if ! use demos; then
     29 		sed -e '/^all:/s:$(DEMOS)::' -i Makefile || die
     30 	fi
     31 }
     32 
     33 src_compile() {
     34 	append-flags -fPIC
     35 	emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" all
     36 }
     37 
     38 src_install() {
     39 	emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" DESTDIR="${D}" install
     40 	use static-libs || rm "${ED}"/usr/$(get_libdir)/${PN}.a || die
     41 	rm "${ED}"/usr/$(get_libdir)/${PN}.la || die
     42 }