logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

libkqueue-2.6.1.ebuild (508B)


  1. # Copyright 2021-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit cmake
  5. DESCRIPTION="kqueue(2) compatibility library"
  6. HOMEPAGE="https://github.com/mheily/libkqueue"
  7. SRC_URI="https://github.com/mheily/libkqueue/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="ISC BSD-2"
  9. SLOT="0/0"
  10. KEYWORDS="~amd64"
  11. IUSE="test"
  12. RESTRICT="!test? ( test )"
  13. src_configure() {
  14. local mycmakeargs=(
  15. -DENABLE_TESTING=$(usex test ON OFF)
  16. )
  17. cmake_src_configure
  18. }