logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

libdazzle-3.34.1.ebuild (1342B)


  1. # Copyright 1999-2019 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome.org meson xdg vala virtualx
  5. DESCRIPTION="Experimental new features for GTK+ and GLib"
  6. HOMEPAGE="https://gitlab.gnome.org/GNOME/libdazzle"
  7. LICENSE="GPL-3+"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
  10. IUSE="gtk-doc +introspection test vala"
  11. REQUIRED_USE="vala? ( introspection )"
  12. RESTRICT="!test? ( test )"
  13. RDEPEND="
  14. >=dev-libs/glib-2.56.0:2
  15. >=x11-libs/gtk+-3.24.0:3[introspection?]
  16. introspection? ( dev-libs/gobject-introspection:= )
  17. "
  18. # libxml2 required for glib-compile-resources; glib-utils for glib-mkenums
  19. DEPEND="${RDEPEND}
  20. vala? ( $(vala_depend) )
  21. dev-libs/libxml2:2
  22. dev-util/glib-utils
  23. virtual/pkgconfig
  24. gtk-doc? ( dev-util/gtk-doc )
  25. "
  26. src_prepare() {
  27. use vala && vala_src_prepare
  28. xdg_src_prepare
  29. }
  30. src_configure() {
  31. local emesonargs=(
  32. -Denable_tracing=false # extra trace debugging that would make things slower
  33. -Denable_profiling=false # -pg passing
  34. # -Denable_rdtscp=false # TODO: CPU_FLAGS_X86 for it?
  35. -Denable_tools=true # /usr/bin/dazzle-list-counters
  36. $(meson_use introspection with_introspection)
  37. $(meson_use vala with_vapi)
  38. $(meson_use gtk-doc enable_gtk_doc)
  39. $(meson_use test enable_tests)
  40. )
  41. meson_src_configure
  42. }
  43. src_test() {
  44. virtx meson_src_test
  45. }