logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

libcss-9999.ebuild (1036B)


  1. # Copyright 1999-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit netsurf git-r3
  5. DESCRIPTION="CSS parser and selection engine, written in C"
  6. HOMEPAGE="http://www.netsurf-browser.org/projects/libcss/"
  7. EGIT_REPO_URI="git://git.netsurf-browser.org/libcss.git"
  8. LICENSE="MIT"
  9. SLOT="0/${PV}"
  10. IUSE="test"
  11. RESTRICT="!test? ( test )"
  12. RDEPEND="
  13. dev-libs/libparserutils
  14. dev-libs/libwapcaplet"
  15. DEPEND="${RDEPEND}
  16. test? ( dev-lang/perl )"
  17. BDEPEND="
  18. >=dev-util/netsurf-buildsystem-1.7-r1
  19. virtual/pkgconfig"
  20. src_prepare() {
  21. default
  22. sed -e '1i#pragma GCC diagnostic ignored "-Wimplicit-fallthrough"' \
  23. -i src/parse/parse.c src/select/arena_hash.h || die
  24. sed -e '1i#pragma GCC diagnostic ignored "-Wmaybe-uninitialized"' \
  25. -i src/parse/parse.c src/select/computed.c || die
  26. }
  27. _emake() {
  28. netsurf_define_makeconf
  29. emake "${NETSURF_MAKECONF[@]}" COMPONENT_TYPE=lib-shared $@
  30. }
  31. src_compile() {
  32. _emake
  33. }
  34. src_test() {
  35. _emake test
  36. }
  37. src_install() {
  38. _emake DESTDIR="${D}" install
  39. }