logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

libbulletml-9999.ebuild (719B)


  1. # Copyright 1999-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit toolchain-funcs git-r3
  5. DESCRIPTION="A Library of Bullet Markup Language"
  6. HOMEPAGE="https://hacktivis.me/git/libbulletml https://shinh.skr.jp/libbulletml/index_en.html"
  7. EGIT_REPO_URI="https://hacktivis.me/git/libbulletml.git"
  8. S="${WORKDIR}/${P}/src"
  9. LICENSE="BSD"
  10. SLOT="0/${PV}"
  11. KEYWORDS="~amd64 ~ppc ~x86"
  12. DEPEND=""
  13. RDEPEND=${DEPEND}
  14. src_configure() {
  15. tc-export AR CXX
  16. }
  17. src_install() {
  18. dolib.a libbulletml.a
  19. insinto /usr/include/bulletml
  20. doins *.h
  21. insinto /usr/include/bulletml/tinyxml
  22. doins tinyxml/tinyxml.h
  23. insinto /usr/include/bulletml/ygg
  24. doins ygg/ygg.h
  25. dodoc ../README*
  26. }