logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

libbulletml-0.0.6.ebuild (1230B)


  1. # Copyright 1999-2022 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit toolchain-funcs
  5. DESCRIPTION="A Library of Bullet Markup Language"
  6. HOMEPAGE="https://shinh.skr.jp/libbulletml/index_en.html"
  7. SRC_URI="
  8. https://shinh.skr.jp/libbulletml/${P}.tar.bz2
  9. https://deb.debian.org/debian/pool/main/b/bulletml/bulletml_0.0.6-7.debian.tar.xz
  10. "
  11. LICENSE="BSD"
  12. SLOT="0"
  13. KEYWORDS="~amd64 ~ppc ~x86"
  14. DEPEND=""
  15. RDEPEND=${DEPEND}
  16. # debian/patches/includes.patch is equivalent to ${P}-gcc43.patch
  17. PATCHES=(
  18. "${FILESDIR}"/${P}-gcc43.patch
  19. "${FILESDIR}"/${P}-Makefile.patch
  20. )
  21. DEB_PATCHES=(
  22. "${WORKDIR}/debian/patches/fixes.patch"
  23. "${WORKDIR}/debian/patches/bulletml_d.patch"
  24. "${WORKDIR}/debian/patches/includes.patch"
  25. "${WORKDIR}/debian/patches/get-rid-of-boost.patch"
  26. )
  27. S="${WORKDIR}"/${PN#lib}/src
  28. src_prepare() {
  29. default
  30. rm -r boost || die
  31. eapply -p2 "${DEB_PATCHES[@]}"
  32. }
  33. src_configure() {
  34. tc-export AR CXX
  35. export CXXFLAGS="-std=c++14 ${CXXFLAGS}"
  36. }
  37. src_install() {
  38. dolib.a libbulletml.a
  39. insinto /usr/include/bulletml
  40. doins *.h
  41. insinto /usr/include/bulletml/tinyxml
  42. doins tinyxml/tinyxml.h
  43. insinto /usr/include/bulletml/ygg
  44. doins ygg/ygg.h
  45. dodoc ../README*
  46. }