logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

gumbo-0.11.0.ebuild (957B)


  1. # Copyright 1999-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit autotools
  5. DESCRIPTION="The HTML5 parsing algorithm implemented as a pure C99 library"
  6. HOMEPAGE="https://codeberg.org/grisha/gumbo-parser"
  7. SRC_URI="https://codeberg.org/grisha/gumbo-parser/archive/0.11.0.tar.gz -> ${P}.tar.gz"
  8. S="${WORKDIR}/gumbo-parser"
  9. LICENSE="Apache-2.0"
  10. SLOT="0"
  11. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~x64-solaris"
  12. IUSE="doc test"
  13. RESTRICT="!test? ( test )"
  14. DEPEND="test? ( dev-cpp/gtest )"
  15. BDEPEND="doc? ( app-doc/doxygen )"
  16. src_prepare() {
  17. default
  18. eautoreconf
  19. }
  20. src_configure() {
  21. econf --disable-static
  22. }
  23. src_compile() {
  24. default
  25. if use doc; then
  26. doxygen || die "doxygen failed"
  27. HTML_DOCS=( docs/html/. )
  28. fi
  29. }
  30. src_install() {
  31. default
  32. use doc && doman docs/man/man3/*
  33. find "${ED}" -name '*.la' -delete || die
  34. }