logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

wasm3-0.5.0.ebuild (716B)


  1. # Copyright 2023 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit cmake
  5. DESCRIPTION="A fast WebAssembly interpreter and the most universal WASM runtime"
  6. HOMEPAGE="https://github.com/wasm3/wasm3"
  7. SRC_URI="https://github.com/wasm3/wasm3/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE=""
  12. src_prepare() {
  13. # WASM blobs formatted as C headers
  14. rm source/extra/*.wasm.h || die
  15. cmake_src_prepare
  16. }
  17. src_configure() {
  18. local mycmakeargs=(
  19. -DBUILD_WASI=simple
  20. )
  21. cmake_src_configure
  22. }
  23. src_install() {
  24. einstalldocs
  25. dobin "${BUILD_DIR}/wasm3"
  26. dolib.a "${BUILD_DIR}source/libm3.a"
  27. }