logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

mrustc-0.10.ebuild (791B)


  1. # Copyright 2022 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="Alternative rust compiler (re-implementation)"
  5. HOMEPAGE="https://github.com/thepowersgang/mrustc"
  6. SRC_URI="https://github.com/thepowersgang/mrustc/archive/refs/tags/v0.10.tar.gz -> ${P}.tar.gz"
  7. LICENSE="MIT"
  8. SLOT="0"
  9. KEYWORDS="~amd64"
  10. IUSE=""
  11. DEPENDS="sys-libs/zlib:="
  12. DOCS=( docs/ Notes/ README.md )
  13. src_prepare() {
  14. default
  15. sed -i \
  16. -e 's/\$(shell git symbolic-ref -q --short HEAD || git describe --tags --exact-match)/v${PV}/' \
  17. -e 's/\$(shell git diff-index --quiet HEAD; echo $$?)/0/' \
  18. Makefile || die
  19. sed -i '/objcopy --only-keep-debug/,/strip/d' Makefile || die
  20. }
  21. src_install() {
  22. einstalldocs
  23. dobin bin/mrustc
  24. }