logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

elixir-1.14_rc0.ebuild (937B)


  1. # Copyright 1999-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="Elixir programming language"
  5. HOMEPAGE="https://elixir-lang.org"
  6. MY_PV=1.14.0-rc.0
  7. SRC_URI="https://github.com/elixir-lang/elixir/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
  8. S="${WORKDIR}/${PN}-${MY_PV}"
  9. LICENSE="Apache-2.0 ErlPL-1.1"
  10. SLOT="0"
  11. KEYWORDS="-amd64 -arm -arm64 -ia64 -ppc -sparc -x86"
  12. IUSE="test"
  13. RESTRICT="!test? ( test )"
  14. DEPEND="
  15. >=dev-lang/erlang-22:0=[ssl]
  16. "
  17. # 'mix' tool collides with sci-biology/phylip, bug #537514
  18. RDEPEND="${DEPEND}
  19. !!sci-biology/phylip
  20. "
  21. DEPEND+="
  22. test? ( dev-vcs/git )
  23. "
  24. PATCHES=(
  25. "${FILESDIR}"/${PN}-1.9.1-disable-network-tests.patch
  26. "${FILESDIR}"/${PN}-1.10.3-no-Q.patch
  27. "${FILESDIR}"/${PN}-1.10.3-epmd-daemon.patch
  28. )
  29. src_install() {
  30. emake DESTDIR="${D}" LIBDIR="$(get_libdir)" PREFIX="${EPREFIX}/usr" install
  31. dodoc README.md CHANGELOG.md CODE_OF_CONDUCT.md
  32. }