logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

elixir-1.13.0.ebuild (886B)


  1. # Copyright 1999-2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="Elixir programming language"
  5. HOMEPAGE="https://elixir-lang.org"
  6. SRC_URI="https://github.com/elixir-lang/elixir/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  7. LICENSE="Apache-2.0 ErlPL-1.1"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~sparc ~x86"
  10. IUSE="test"
  11. RESTRICT="!test? ( test )"
  12. DEPEND="
  13. >=dev-lang/erlang-22:0=[ssl]
  14. "
  15. # 'mix' tool collides with sci-biology/phylip, bug #537514
  16. RDEPEND="${DEPEND}
  17. !!sci-biology/phylip
  18. "
  19. DEPEND+="
  20. test? ( dev-vcs/git )
  21. "
  22. PATCHES=(
  23. "${FILESDIR}"/${PN}-1.9.1-disable-network-tests.patch
  24. "${FILESDIR}"/${PN}-1.10.3-no-Q.patch
  25. "${FILESDIR}"/${PN}-1.10.3-epmd-daemon.patch
  26. )
  27. src_install() {
  28. emake DESTDIR="${D}" LIBDIR="$(get_libdir)" PREFIX="${EPREFIX}/usr" install
  29. dodoc README.md CHANGELOG.md CODE_OF_CONDUCT.md
  30. }