logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

xkbcommon-9999.ebuild (735B)


  1. # Copyright 2018-2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. CABAL_FEATURES="lib"
  5. inherit haskell-cabal git-r3
  6. DESCRIPTION="Haskell bindings for libxkbcommon (Waymonad)"
  7. HOMEPAGE="https://github.com/Ongy/haskell-xkbcommon"
  8. EGIT_REPO_URI="https://github.com/Ongy/haskell-xkbcommon.git"
  9. EGIT_SUBMODULES=()
  10. SLOT="0"
  11. LICENSE="BSD MIT"
  12. IUSE="test"
  13. # Shipped in GHC: bytestring, filepath, process, template-haskell, time, unix
  14. DEPEND="
  15. dev-haskell/transformers
  16. dev-haskell/storable-record
  17. dev-haskell/cpphs
  18. dev-haskell/text
  19. dev-haskell/data-flags
  20. dev-haskell/c2hs
  21. x11-libs/libxkbcommon
  22. test? (
  23. dev-haskell/random
  24. dev-haskell/vector
  25. )
  26. "