logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

hayland-9999.ebuild (887B)


  1. # Copyright 2019 Haelwenn (lanodan) Monnier <contact@hacktivis.me>
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. CABAL_FEATURES="lib"
  5. inherit haskell-cabal git-r3
  6. DESCRIPTION="Haskell bindings to Wayland library (Waymonad fork)"
  7. HOMEPAGE="https://github.com/Ongy/haskell-wayland"
  8. EGIT_REPO_URI="https://github.com/Ongy/haskell-wayland.git"
  9. EGIT_SUBMODULES=()
  10. SLOT="0"
  11. LICENSE="MIT"
  12. # Shipped in GHC: process, template-haskell, time
  13. # Note: Build failed with =dev-haskell/c2hs-0.16.5::haskell, seems related to
  14. # https://github.com/haskell/c2hs/issues/192 so I upped the version
  15. # requirements of c2hs and language-c instead of copying from the cabal file.
  16. DEPEND="
  17. dev-haskell/xml
  18. dev-haskell/data-flags
  19. dev-haskell/transformers
  20. >=dev-haskell/c2hs-0.28
  21. >=dev-haskell/language-c-0.7.0
  22. virtual/pkgconfig
  23. "
  24. RESTRICT="test" # Assumes weston is running