logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

madeline-9999.ebuild (510B)


  1. # Copyright 2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit git-r3
  5. DESCRIPTION="tiny readline-alike with some batteries included"
  6. HOMEPAGE="https://git.d2evs.net/~ecs/madeline/"
  7. EGIT_REPO_URI="https://git.d2evs.net/~ecs/madeline/"
  8. LICENSE="WTFPL-2"
  9. SLOT="0"
  10. DEPEND="dev-lang/hare"
  11. RDEPEND="${DEPEND}"
  12. DOCS=( README example.ha )
  13. src_install() {
  14. einstalldocs
  15. # No Makefile present
  16. insinto "${EROOT}/usr/src/hare/third-party/"
  17. doins -r graph made
  18. }