logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

hare-sdl2-9999.ebuild (513B)


  1. # Copyright 2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit git-r3
  5. DESCRIPTION="SDL2 bindings for Hare"
  6. HOMEPAGE="https://sr.ht/~sircmpwn/hare-sdl2"
  7. EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/hare-sdl2"
  8. LICENSE="MPL-2.0"
  9. SLOT="0"
  10. DEPEND="
  11. dev-lang/hare
  12. media-libs/libsdl2
  13. media-libs/sdl2-image
  14. media-libs/sdl2-mixer
  15. "
  16. RDEPEND="${DEPEND}"
  17. src_install() {
  18. # No install target in Makefile
  19. insinto "${EROOT}/usr/src/hare/third-party/"
  20. doins -r sdl2
  21. }