logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

godef-1.1.2.ebuild (1459B)


  1. # Copyright 2019-2020 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit go-module
  5. DESCRIPTION="detect licenses used in Go binaries"
  6. HOMEPAGE="https://github.com/mitchellh/golicense"
  7. EGO_SUM=(
  8. "9fans.net/go v0.0.0-20181112161441-237454027057"
  9. "9fans.net/go v0.0.0-20181112161441-237454027057/go.mod"
  10. "golang.org/x/crypto v0.0.0-20190308221718-c2843e01d9a2/go.mod"
  11. "golang.org/x/crypto v0.0.0-20191011191535-87dc89f01550/go.mod"
  12. "golang.org/x/mod v0.1.1-0.20191105210325-c90efee705ee"
  13. "golang.org/x/mod v0.1.1-0.20191105210325-c90efee705ee/go.mod"
  14. "golang.org/x/net v0.0.0-20190404232315-eb5bcb51f2a3/go.mod"
  15. "golang.org/x/net v0.0.0-20190620200207-3b0461eec859/go.mod"
  16. "golang.org/x/sync v0.0.0-20190423024810-112230192c58/go.mod"
  17. "golang.org/x/sys v0.0.0-20190215142949-d0b11bdaac8a/go.mod"
  18. "golang.org/x/sys v0.0.0-20190412213103-97732733099d/go.mod"
  19. "golang.org/x/text v0.3.0/go.mod"
  20. "golang.org/x/tools v0.0.0-20200226224502-204d844ad48d"
  21. "golang.org/x/tools v0.0.0-20200226224502-204d844ad48d/go.mod"
  22. "golang.org/x/xerrors v0.0.0-20191011141410-1b5146add898"
  23. "golang.org/x/xerrors v0.0.0-20191011141410-1b5146add898/go.mod"
  24. )
  25. go-module_set_globals
  26. SRC_URI="https://github.com/rogpeppe/godef/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
  27. ${EGO_SUM_SRC_URI}"
  28. LICENSE="BSD MIT"
  29. SLOT="0"
  30. KEYWORDS="~amd64 ~ppc64"
  31. src_compile() {
  32. go build || die
  33. }
  34. src_install() {
  35. default
  36. dobin ${PN}
  37. }