logo

overlay

My own overlay for experimentations, use with caution, no support is provided git clone https://hacktivis.me/git/overlay.git

unite-0.4.0.ebuild (628B)


  1. # Copyright 1999-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. inherit rebar3
  5. DESCRIPTION="Pretty EUnit test formatters"
  6. HOMEPAGE="https://github.com/eproxus/meck"
  7. SRC_URI="https://github.com/eproxus/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
  11. IUSE="test"
  12. RESTRICT="!test? ( test )"
  13. DEPEND="
  14. >=dev-erlang/color-1.0.0
  15. >=dev-erlang/tdiff-0.1.2
  16. "
  17. RDEPEND="${DEPEND}"
  18. # uses ex_doc
  19. DOCS=( CHANGELOG.md README.md )
  20. src_prepare() {
  21. rebar3_src_prepare
  22. sed -i '/{project_plugins,/d' rebar.config || die
  23. }